Author Topic: Correcting images no longer visible in some threads (Chrome browser problem)  (Read 3552 times)

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
I'm not sure if you're posting images recently. I get the impression that you are, but I can't see them or any sign that they're there.
« Last Edit: November 25, 2020, 11:10:06 PM by vtsteam »

Offline russ57

  • Sr. Member
  • ****
  • Posts: 270
I can see them.
Are you logged in?

Edit... Duh, you must be or you couldn't reply....
-russ

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8725
  • Country: gb
  • East Sussex, UK
I see no pictures in post #43
Andrew Mawson
East Sussex

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
Now what's changed? I've looked back over the project and the only image that I can see is on post No. 2.

There's nothing in any of the posts to show that there is, or should be, an image  :scratch: :scratch:

Offline WeldingRod

  • Sr. Member
  • ****
  • Posts: 398
Workin' for me...

Sent from my SM-G892A using Tapatalk


Offline vtsteam

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6407
  • Country: us
  • Republic of Vermont
Works for me.

There may have been an expired security certificate for the host of the photos not showing. I'm going to guess that it has since been renewed. All of the posts except the one in reply #2 are http links to one server, while the posts in #2 one is an https link on a different server. (I had the same problem with my own photos yesterday when my security cert expired, until I renewed it. Modern browsers no longer accept plain http links -- they want working https or nothing. Irritating)

Anyway sorry about the digression. Sorveltaja continuing to be terribly impressed with your search for personal guitar feel perfection. Though I don't play guitar, it's just fun to watch you work through all these combinations.  :bow: :beer:
I love it when a Plan B comes together!
Steve
https://www.youtube.com/watch?v=4sDubB0-REg

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8725
  • Country: gb
  • East Sussex, UK
Nope, still no pictures :(
Andrew Mawson
East Sussex

Offline vtsteam

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6407
  • Country: us
  • Republic of Vermont
Still seeing them, Andrew can you directly access in your browser:

Code: [Select]
http://www.elisanet.fi/kz1706/scalloping/Trem_bar_and_linkages.png
I love it when a Plan B comes together!
Steve
https://www.youtube.com/watch?v=4sDubB0-REg

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
I've looked at the page source code. There are no hyperlinks to any images other than that first one in post No.2. There's definitely something awry.

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8725
  • Country: gb
  • East Sussex, UK
Steve yes your link gives me a picture - all very odd  :scratch:
Andrew Mawson
East Sussex

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
Andrew, see if you can see an image link in one of the pages' source code. They're just not there when I look. The one in post 2 is an https: link. I'm wondering if there's a setting in my browser that prevents access, or even displaying of, http: links and just allows https: links.

Offline RussellT

  • Hero Member
  • *****
  • Posts: 514
  • Country: gb
Well I can't see pictures either.  I assumed it was a problem here but it seems it may not be.  I was going to investigate when I had a chance.

Interestingly if I view the source all the picture links are there but don't show in the page.  If I copy the source to Notepad and save as an html file then I can open that and all the pictures are visible.  That makes me suspect the
Code: [Select]
class="bbc_img" part of the image link.

The other question that springs to mind as some can see it and others can't is what browser you are using.  I am using Chrome.

Russell
Common sense is unfortunately not as common as its name suggests.

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8725
  • Country: gb
  • East Sussex, UK
Chrome here too.
Andrew Mawson
East Sussex

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
I'm using Chrome as well. As stated, I can't even see the links.

Offline kayzed1

  • Sr. Member
  • ****
  • Posts: 287

FireFox here and all is well.

Offline pycoed

  • Jr. Member
  • **
  • Posts: 67
Chromium shows pictures fine for me, but Google Chrome on laptop does not? Perhaps I have some differences in the settings, but I haven't noticed any other hiccups (both on Ubuntu)

Offline vtsteam

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6407
  • Country: us
  • Republic of Vermont
The link I gave is to one of the "source code" page images seadog. They are all present.

Yes, Google for some reason has decided for you all using current Chrome browsers, that you can't view plain http addressed images through this site any more. Chromium developers have not made that decision for you, and Mozilla developers give you a popup note choice to view so-called "insecure content", although with an initial dire warning. "This looks bad". If you give permission, it will store the site as an security exception, and won't bother you any more.

Actually, https websites can be just as bad actors as http websites. All you need is a temporary certificate issued by a free authority to add https to your page, and all they require for verification is that you prove you can serve up a specific verification file. Not what you serve on the page itself. Could be anything.

FYI I see all images on all of this thread's pages. I use a Mozilla browser. All photos are present, and the links are properly there in all of the posts, if I momentarily go into edit mode to view them. They are all http links, except the one in reply #2, which is https, and presumably visible to you all.

Experiment:

See if you can change the actual address of this whole page to http ifrom https from you browsers address bar. Does that stick when you refresh the page, and can you then see the one image on this page? Please report yes or no, and what browser you are using....
I love it when a Plan B comes together!
Steve
https://www.youtube.com/watch?v=4sDubB0-REg

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
Hi Steve, that does the trick, but obviously it only holds true for that page. I'll have to have a nose around to see if I can find a setting in Chrome.

Offline RussellT

  • Hero Member
  • *****
  • Posts: 514
  • Country: gb
Thanks Steve.

To fix it, go to Settings, Privacy and Security, Site Settings, Insecure Content.

Expand the Insecure content section and click Add on the "Allow" section.  Type madmodder.net and then Add.  That should fix it.

Russell
Common sense is unfortunately not as common as its name suggests.

Offline Sea.dog

  • Full Member
  • ***
  • Posts: 222
  • Country: gb
  • Up Spirits!
Well done that man   :thumbup:  :beer::beer:  :ddb:

Offline philf

  • Hero Member
  • *****
  • Posts: 1009
  • Country: gb
Thanks Steve.

To fix it, go to Settings, Privacy and Security, Site Settings, Insecure Content.

Expand the Insecure content section and click Add on the "Allow" section.  Type madmodder.net and then Add.  That should fix it.

Russell

Russell - I went about it via a different route. I clicked on "Not Secure" in the address bar to the left of madmodder.net.

This brings up a window. Click on "Settings".

Scroll down to "Insecure Content" and change the setting to "Allow".

This gives permission to allow insecure content just for madmodder.net

It's fixed the images in Chrome on my Windows 10 laptop.

Edge shows images on both my laptop and Android tablet.

I've yet to find how to fix Chrome on my tablet. If anyone has a fix I'd appreciate them sharing it.

Edit: Just found this: https://www.androidheadlines.com/2020/02/google-insecure-mixed-content-downloads-block-chrome-82.html
Phil Fern
Location: Marple, Cheshire