Author Topic: It's BIG, Yellow and digs holes! JCB 3CX Project 8 is joining the Tractor Shed  (Read 17935 times)

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8781
  • Country: gb
  • East Sussex, UK
Too right Steve and Phil !

So today having totally failed removing the last screw retaining the cover round the loader controls I set too with my Fein Multi-Tool with my longest protruding 'end on' saw blade and cut a rectangle round the bolt head thus releasing the cover from the offending bolt. Then a bit of juggling to get the control levers disengaged from their rubber gaiters and at last 'the dog could see the rabbit' !

The tone tracer soon found me cable 303 - there are a pair of round plugs and sockets in the loom under this cover, and a 'proper job' would be to release them, release the pin for wire 303 and replace it, but where I have disconnected other plugs and sockets on this machine I entered a whole world of pain so this time just trimmed the cable back to a pig tale and crimped a new piece of 1.5 mm stranded and tinned cable, threading it through the floor grommet and down to the loom that runs above the chassis rail where it was crimped to the original end of wire 303 that goes onwards to the cab roof.

After much testing to prove that I hadn't disturbed anything else and that the 12v permanent feed to the cab was sound I re-bound the loom. Two wraps of ordinary sticky pvc tape first to draw the cables into a tight bundle followed by a wrap of self amalgamating tape and an over cover of Hellerman Spiral Cable Protector. Ty-wraps replaced holding it all out of danger and the rest of the gubbins could go back on. Great fun working in that cab - not a lot of room to get at things.

. . . what a lot of fuss for a single wire . . . but it's done now AND works. Things like the self parking feature of the wipers previously didn't work as they use this live feed to get back to home position - now they do  :ddb:

Rear wheel put on with the able assistance of our new young gardener Eliot - Clive having retired - I wouldn't have been able to do it single handed without a lot of messing about.
Andrew Mawson
East Sussex

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8781
  • Country: gb
  • East Sussex, UK
Continuing clearing the various electrical gremlins in this machine I turned my attention the the 'Face Level Fan'.

As received about a year ago, this fan was lying loose on the floor of the machine amongst all the detritus and rubbish that I had to clear out - It's bracket had broken and it's source cable had been pulled out of the cab light fitting where someone had lashed it in rather crudely previously. I'd already superglued the bracket once but it wasn't strong enough, and it's been kicking about on my desk giving me resentful looks ever since.

OK make a stronger bracket out of brass. The original plastic one had been fixed with two self tapping screws into the cab frame, and rather than end up with loads of holes in the frame I stuck with the same spacing, marking out the same shape on a bit of thick brass sheet kindly donated by the plunger EDM machine.

The central thread was 16 mm o/d by 1.5 mm pitch, and by sticking with the same size I could re-use the original retaining knob.Roughing out the holes & slots on the milling machine and the overall shape on the band saw gave me an approximate shape to file and band face to the correct dimensions.

Then the male 16 mm thread was silver brazed into the mounting plate and everything cleaned up on the wire wheel before a test fit. I increased the size of the mounting screws as the previous ones were a bit wimpy and countersunk the plate to receive them so as not to foul the fan itself.

In all a simple but satisfying repair - or is it a reconstruction?.

While I was tracing the fault that prevented the cab light working I had come across the correct wiring feed from the main cab loom for this fan (The fan was an optional extra and although this is the correct fan it's a retrofit) and rather than have the wiring 'hard wired' I'm fitting a plug and socket arrangement so the fan can actually be easily removed if it gets in the way.

JCB on the 3CX use a special socket and plug for things like the flashing beacon rather than a standard 'cigarette lighter' socket so I will use one of the JCB one in order to keep consistency. There are two varieties of the socket. A 'surface mount' version which would be much easier to mount, and a through panel version that is a much nicer bit of construction, but there isn't enough depth behind the relevant panel. I suspect I'll go with the later version and make a little box to mount it but the jury is still out on this.

Continuing the concept of sorting electrical gremlins the cab clock, which now tells the time following fixing the cab light,doesn't work in the 'back light' department - only a bulb, but a special bulb which is now on order.

Strangely the clock has four wires going to it:

1 - Ground
2 - permanent 12 v to keep time going
3 - 12 v from ignition switch
4 - 12 v from side light circuit

As the side lights can be put on without the ignition I can only assume that there are diodes between the ignition 12 volt feed and side light feed to stop it back feeding.

Seems a bit of a luxury having the clock light on when the side lights are on - an added complexity to the wiring loom !


 
Andrew Mawson
East Sussex

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8781
  • Country: gb
  • East Sussex, UK
The 'special' bulb for the clock back light arrived - odd little things that have wings that poke through a hole in a printed circuit board, and ramps on the wings tighten the connection - well they do when the ramp has been re-bent !

However back light still not working (though original bulb WAS blown and new one IS OK  :scratch:) - time for more investigations. Metering the four pole connector on the wiring loom, Ground was where I expected it, 12 volt permanent was there for the clock itself, as was the feed for when the ignition is on, and separately the feed for when the side lights are on for the clock back light. Problem MUST be within the clock module itself.

Time for a bit of brain surgery. Usual 'popping plastic clips' dismantling got me inside. Sure enough as I previously postulated, the feeds from the Ignition and the Side Lights each go straight to their own isolating diode, with their cathodes being commoned and going to one side of the light bulb. I would expect the other side of the bulb to be taken directly to Ground - but no, no sign of any connection to it - certainly none to anything that was accessible.

I should point out that this clock module is a 'sandwich ' of two PCBs separated by riveted and soldered spacers that would be virtually impossible to undo without damaging other bits.

Fortunately I was able to poke a fine tipped soldering iron in between the two PCB's and put a 'salvage link' from a bit of track from the o/c side of the  bulb to the rear of the Ground input pin.

. . . let there be light . . . and there was, both with just the side lights, and also with the ignition being on.   :clap:

Just one more gremlin knocked on the head - getting there  :thumbup:
Andrew Mawson
East Sussex

Offline Spurry

  • Sr. Member
  • ****
  • Posts: 342
  • Country: england
  • Norfolk, UK
Yet another job well done, Andrew. Those little bulbs seem to have been well-used by JCB in the past, but are no longer listed as spares apparently.
Are yours pattern parts? The only ones I could find (for my neighbours JCB loader) were the integrated ones with bulbs fixed into the holder, but there used to be some holders with a removable glass section.
Pete

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8781
  • Country: gb
  • East Sussex, UK
Pete the original ones have a 'pea' bulb soldered to the wing contacts of the holder - they were available for about 5 each. I bought a pack off ebay of clone for 3.13 including postage. The black plastic is noticably softer than the originals, and I had to tweak the wings to make proper contact, but they work. My side console dash is tull of them hence the x10 purchase !

https://www.ebay.co.uk/itm/354054545304
Andrew Mawson
East Sussex

Offline awemawson

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8781
  • Country: gb
  • East Sussex, UK
I finally finished fitting the face level fan  :thumbup:

(how alliterative was that  :lol:)

I'd sourced a neat little die cast box off eBay (though actually Rapid Electronics) and fitted it to the cab a few days ago, and was waiting for a 'curly cable' - again from eBay. The fan can be moved to point at you whether you are in the front or back seat, so I decided that the extra movement of the curly cable was well worth while - anyway it was only 2 ! Obviously surplus from some nice equipment as it is super fine strands with reinforcing cotton or polyester up the middle. Mind you this meant that it had to be terminated with crimps and ferrules.

The original connection at the fan end was by 1/8" miniature push on 'mini lucar' connectors which amazingly I had in stock from some long forgotten project so I was able to do a pretty neat job of it.

All connected up and working on both speeds (knob Off - Slow - Fast co-axial with fan motor) it's another 'little job' put to bed.

Andrew Mawson
East Sussex